Default Email Application

In General settings, under Default Email Application, the request to make eM Client the default email application is not accepted. my OS is Windows 10. On the Windows 10 settings screen EM Client is shown as the default. The eM Client settings screen says it is not the default.

Not sure where the problem is after several requests.

Not sure where the problem originates, but you can set eM Client as the default in Windows Control Panel. Go to Programs > Default Programs > Set your default programs.

Click on eM Client. Choose Choose defaults for this program.

Choose Select All , and Save.

Incidently, I thought that this problem was resolved in the latest version. If you are still on a previous version, you might consider downloading and installing the latest from

I am on the latest version. Downloaded on 26 February 2018. Version

I did notice one thing, that when you click the Make Default button in eM Client settings, and it takes you to Windows Default Apps window. Changing the default email application on that screen sometimes does not appear to have worked. If you close the window and come back, eM Client is correctly set as default. The only thing that does not set is .eml files.

Anyway, the Control Panel method does everything.

Yes, I’ve set it in the Windows Default Apps window and it doesn’t change it in eM Client. I am struggling at the moment to get to the same screen as you have shown above in Control Panel.

Try WinKey + R

Then type in control /name Microsoft.DefaultPrograms /page pageDefaultProgram

That should get you to that page that lists all the applications. Then just click on eM Client etc.

It may look different in your version of Windows 10.  I have the Fall Creators edition and mine looks different than Gary’s.
1.  Click on the notifications box at the lower right portion of the Windows screen.  Select “All Settings”, “Apps”, “Default Apps”, then at the bottom of that screen, select “Defaults by App”. 

2.  Scroll down to eM Client, click on it and then click on the “Manage” button.  make sure all the mail protocols are set to eM Client.  If they are not, click on the incorrect program icon and choose eM Client

I’m pretty sure that Windows no longer allows a (non-Microsoft?) program to set the default app, it must be done through settings.  I believe the fix in this version of the program relates to eM Client displaying itself as the default app in the Fall Creators edition.

Also, Windows is definitely getting away from the control panel and going to their standardized settings menu system.  But at this point you can still get to this menu through settings or the control panel.

Yeah, sorry we don’t use the Fall Creator’s edition, so could not provide that route. Thanks Jay. In older versions when you click on Defaults by App, you get the Control Panel page instead of the new window.

I think that even if the Control Panel does eventually get hidden, it will still be able to be accessed through the control /name method.

Yes, thanks Jay. I used your suggestion, through the notification box in Windows, to change the mail protocols to eM Client and this has changed the label in eM Client settings to ‘This application is the default mail handler’.

I am using Windows 10 Home, version 1709 - the Fall Creators version.