Constant crashing (AGAIN!)

After abandoning your earlier crashing releases of V8 and going back to my, 100% stable V7, I thought I would try and buy your latest version 8 (8.1.979.0). Oh dear! It lasts around 90 seconds before it crashes without any warning. I’ve tried every solution that your site suggests but it still crashes. I’ve raised yet another fault log but I’m not holding my breath and think I’ll be looking for my refund again!
I know this gets raised often on this forum but maybe it might get fixed soon?

Does it? I know there were one or two queries and they address different things, but I never experienced it myself, and I never saw complaints from the 10s of thousands of other users.

This may have to do with something else and not the application. Best to wait for your support ticket to be addressed to find the cause.

I appreciate your input but you are obviously not searching either these forums or the Web very thoroughly. This is a well known and, for a large number of us, a serious problem. It has been in existence since the initial release of V8. Every other program/app on my machine, including V7 of eM, runs perfectly so I do not understand why you think it is my laptop.
Still, I await a response from support.

That is the best option.

But if you want assistance on this forum, rather than just say you have tried every solution suggested, could you be a little more specific about what you have tried, otherwise it makes it difficult for your fellow users to make suggestions. Maybe you did not search the forum as well as you think and have missed something. Maybe you just missed a crucial step. We certainly will not know if you haven’t said anything.

I still don’t see the evidence that a large number of users have this issue. Maybe they are discussing this elsewhere on the Internet as you suggest, but that doesn’t help at all if they don’t discuss it here.

Sorry for barging in on this post, but had to say that I’m also having issues with the application crashing. I see others as well, but maybe not the volume this user has seen. IMHO, it seems that there is definitely something going on with this app. I’m having a heck of a time with repeated crashes. I was tempted to upgrade, but now I’m not sure I want to. I spent a lot of time last year researching an email application to switch to from Outlook (outlook just doesn’t handle smtp very well) and this looked promising. It was never as full featured as I thought it was and the constant DB repairs are annoying. I’ve heard people say things like, “ah! you renamed the database folder and now it’s working! It wasn’t the application, it was the database!” Well, it’s both. How the application is handling the database is a huge part of the application.
At any rate, if the user is still having issues, they can take a look at the log files and see if they can get a hint as to the error or even the timing of the incident (when it crashed). Log files can be found here:
“C:\Users%usernamehere%\AppData\Roaming\eM Client\Logs”
for me, I see 3 logs.
Auth.Log * this is an authentication log
SQLITE.LOG * this is a DataBase Log
CEF.LOG * this is probably a general log- “common event form”–general formatting for log events.

The last crash I had stated something along these lines:
Auth.log was good. it found the yahoo issue, but was able to update and resolve itself
SQLITE.LOG: 09:35:37 283 recovered 8 frames from WAL file from: AppData\Local\eM Client\Avatar Cache.62b578f82a2383edbc1b86438084d87c\failed_requests.dat-wal
Definitely the DB was having issues with the cache
and then the CEF.LOG
[0109/013527.296:ERROR:viz_main_impl.cc(169)] Exiting GPU process due to errors during initialization
That looks promising. So the Graphical Processing Unit had something to do with it…
Gives me a good lead. Update the drivers, check the chipset, even launch in ‘Safe Mode’ (vga bypasses the typical drivers and features that may be causing issues).

For the user, there may not be much of anything. But if they at least have the time, then they can look through the Windows Event Logs and correlate the time of the application crash and another process launching or another error happening around the same time.

As for me, this is really unfortunate. It’s been years since I’ve had an application not only crash, but take down my whole system with it.
I’ve restored, taken out the DB completely, ran application debugging tools, watched process and looked at everything EM Mail touched when launching. I even ran repairs on the DB using sqlite tools (always using a backup copy of the DB of course).
I’m not sure I want to go through and troubleshoot this anymore because after it’s all said and done, my 8 accounts will undoubtedly be loading as fast as it did before this issue started. Unfortunately, my ‘Pro’ account expired 2 months ago (figures right?) so that level of support is out the door. I was hoping 8.1 would be faster and I can keep using this app, but judging by some of the comments, speed wasn’t something that was updated. I thought I read that the DB format was changed, so maybe it’s indexed better? Anyway, good luck and I hope you find a solution!

Stay safe,
Voltron

CEF errors can usually be solved by uninstalling the application, and making sure there is nothing left in C:\Program Files (x86)\eM Client, then downloading the latest version from the Release History and installing that. eM Client also depends on a few things in your system, so make sure your OS is fully updated. Especially .NET. You can also start the computer in Safe Mode and see what happens.

The avatar cache (~AppData\Local\eM Client\Avatar Cache) you can just delete if it is giving an error. After restarting eM Client it will repopulate.

That is always an issue, and why many threads on this forum just suddenly stop without a resolution. At least you have given some clue as to what you discovered as errors, and that helps when suggesting things to try. Thanks Roy. Some users just state that they tried every solution without giving any details of errors or what exactly they tried which is of no help at all.

1 Like

Me again! OK, you asked for a little more detail.
I fully uninstalled V7, having first renamed the storage file “old”, then removed any references in the appropriate x86 file to eM Client. I also did a registry sweep for old entries and removed them. I then installed the latest V8 from the “release” page and all went well. I restarted the laptop, opened eM Client and restored from the backup file as I have 5 accounts. Google calender and contacts synced perfectly and the program succesfully downloaded some new mails. I thought that was that but two minutes later, I looked at the laptop and the program had closed with no action on my part. Restarting opened the closed improperly dialogue so I let it sort out the database and it eventually reopened the program. Shortly after that, with no action n my part, it crashed. I then had a few more goes before abandoning it and going back to V7. As yet, no response from support but these are difficult times and I expect the answer to be slower than normal.

This means something is interfering with eM Client, or there is something wrong with the database. Please do the same but with Windows running in Safe Mode and see if you get the same result.

OK, I tried that “Safe” mode and V8 (latest version) was stable on 1 GMail account and functioned as I expected so, after about a couple of hours, I restored my database using the “restore” choice and it trundled away for a while and then reopened. All was there for five minutes, then the program crashed. I reopened it, allowed it to perform a full check and it reopened. This time it was open for 2 minutes and crashed. Have gone back to V7 (latest version) running under Win 10 and it’s absolutely perfect. What could be affecting V8 so badly that is not a problem for V7? I do not understand how one version can run without any problem and the latest version won’t run at all!

So you are saying it was fine until you restored the previous database?

Indeed I am. That’s why I’m mystified.

There was another user who was experiencing crashes in 8 after importing a version 7 database. Please read this thread and see if it looks like a similar issue: Version 8.1 won’t start

My advice is to export all your data from eM Client, then delete the database. Once you have restarted eM Client, add your accounts and import your data again.

If you have lots of accounts and other settings, you can export those as well just to make it a bit easier.

image

I’m the one who posted that and I didn’t have any luck either with restoring the backup file made in v7. I really think if you try what Gary just said that should work. I used this same method when my v7 database got corrupted and it fixed it.

Forget about the backup file or your database (but back it up), just use the export feature. Export all your emails as EML files and import it all back in. Export your settings. If you do this while doing something else like eating, TV, or sleeping, the time it takes won’t be an issue.

This is my plan for later after they fix the spell checker. Let us know if you have any success - at this point we all need hope this will work.

1 Like

Hello Gary, I tried all that and it was all going really well until I tried to import one “sent” folder and the program just gave a blue wheel of death and crashed. I let it sort itself out on reopening and tried again and it immediately crashed. So, at a guess, I would say that the problem lies in that “sent” box which is vital to me. I’ve gone back to V7 which works and I think I’ll just stay with that. I should not be having problems with the likes of corrupt databases and installation difficulties with a new version, it should just work like V7 does every single time. Might I thank you ( &Gerry) for all your effort but this is no use. I do know what I’m doing with PCs most of the time but this has beaten me.

I am hoping that because there are a few threads on this forum discussing crashing in 8.1, and even if it is only a few users, that someone from eM Client might make a useful comment regarding this.

Yeah, sticking with what works is probably the best decision.

Obviously must be something in my laptop that’s causing this but I’ve no idea what as it causes no problems with V7. So, it’s back to V7 for me. But thank you so much for your help in this. I’ll wait and see if tech support come up with anything but there’s been no response so far.

I feel your frustration Max - been there. If you exported your Sent as EML files, You can go to the Sent exported folder and you’ll see the tons of emails.

Maybe divide it up in 4 parts and import 1 at a time until you find the offending emails. Also there is a DB Repair EXE file in your Em Client Program files folder that you can try before any of that. Hope it works