Connection failed error after last update

Hello everyone!

I was working with eM Client with no issues, and today I got this “New version available!” So I downloaded and installed it, and after that, I see a yellow exclamation sign next to my address showing this error: “Connection failed. An attempt to connect to x@x.x failed. This could be caused by temporary server unavailability or incorrect settings”.

There are no errors shown, I did not change any settings and the server is working fine as I can read email from other clients, including webmail.

Log:

9:18:14  [IMAP]  Synchronizing message flags: For folder /Sent Messages
9:18:15 [IMAP]  Synchronizing message flags: Listo
9:18:15 [IMAP]  Synchronizing message flags: For folder /Sent Messages
9:18:16  [IMAP]  Synchronizing message flags: Listo
9:18:16 MailClient.Accounts.ConnectionException: 
9:18:16 ()
9:18:16    en MailClient.Protocols.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
9:18:16    en MailClient.Protocols.Imap.Synchronizer.SynchronizeFlagsCommand.ExecuteInternal2(WorkerStatus status, ConnectionContext context)
9:18:16    en MailClient.Protocols.Imap.Synchronizer.SynchronizeFlagsCommand.ExecuteInternal(WorkerStatus status)
9:18:16    en MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
9:18:16    en MailClient.Commands.Command.Process(WorkerStatus status)

Any help is welcome, thanks so much!

Can you disable your anti-virus/firewall application, then try again.

If that does not work, you can uninstall eM Client, making sure NOT to delete the database, then download and install the previous version of eM Client from the Release History.

Thanks Gary, antivirus/firewall did not work. Where is the database so I can back it up?

In eM Client go to Menu > File > Backup. On Windows the backup.zip will be saved to a directory in your documents folder.

Thanks, trying now!

Worked perfectly, so there is something wrong with the new version, at least for me. Thanks so much Gary!

Have the same problem with new release

And what happens when you downgrade, Stephen?

I have the same problem with the new release.  I don’t have time today to downgrade I’m afraid.  Weirdly, I still can get some messages received, and the exclamation goes away for a bit.  Then comes back. 

Here are the errors I see in the IMAP log:
14:10:04.710|029|   * BYE [ALERT] Fatal error: max atom size too small: 
14:10:04.711|01B|   Exception: MailClient.Accounts.ConnectionException: 
()
14:10:04.711|01B|      at MailClient.Protocols.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
14:10:04.711|01B|      at MailClient.Protocols.Imap.Synchronizer.SynchronizeFlagsCommand.ExecuteInternal2(WorkerStatus status, ConnectionContext context)
14:10:04.711|01B|      at MailClient.Protocols.Imap.Synchronizer.SynchronizeFlagsCommand.ExecuteInternal(WorkerStatus status)
14:10:04.711|01B|      at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
14:10:04.711|01B|      at MailClient.Commands.Command.Process(WorkerStatus status)
14:10:04.712|01E|   AccountBase.ChangeOnlineState : STATE CHANGE TO offline due BrokenConnection

eM Client has made a comment at https://forum.emclient.com/emclient/topics/update-to-7-2-36465-0-errors that might help.

I suggest uninstall and then reinstall the previous version that we know works.

The error is happening because the emClient is sending a “STORE (super long list) +FLAGS.SILENT” command. That apparently exceeds some limit of the listed flags. I wonder if there is someway to make the emClient not send this request to change the flags or to get the client to just change a few at a time.

the same is happening to me i get a red explanation when trying to add a non gmail accounr

every working again after downgrade