Composing email - does tab not insert a tab character?

When I compose an email, regardless of whether I’m using text format or html format, the tab key inserts four spaces. I don’t hate this behavior (though it is incredible there’s no option to make tab insert an actual tab character), the real problem I’m having is that if I copy text from elsewhere (like code from Eclipse) and paste it into an email, tabs are completely ignored, and don’t even show up as four spaces. What. The. F*ck?