Column changes for Contact views are not saved

Changes to columns in a view in Contacts are not saved between sessions. Even ‘Custom View’ always reverts to the default (all columns) when I restart eM Client.

Using version 6 on Windows 7 with contacts from a Gmail account.

Hi, can you tell me the exact number version of your client? You can find the number in Help > About.

Thank you,
Paul.

I am seeing exactly the same problem with client version 6.0.19861.0 If I apply a customization to the columns when viewing ‘Contacts’, and then apply customization to other folders, and select ( as an example ) ‘My Contacts’ then although the customization is applied immediately, upon a restart of the client all changes except those made to the original ‘Contacts’ are lost and it reverts to the default view…

First please update to this version (http://www.emclient.com/dist/v6.0.201…) so we can make sure this is not a fixed issue, even though this hasn’t been reported previously.

If it doesn’t work, could you possibly make few screenshots of the issue to post here?

Thank you,
Paul.

I have observed similar problems. I display Contacts in “Custom View” with sub-folders for the various categories.
I use “Column configuration” to remove most of the default columns, leaving just the few which I require. After closing and restarting the application, I always found that my column selection was preserved for the main “Contacts” folder but that the category sub-folders reverted to the default columns.

I have just upgraded to v6.0.20.154 and have re-tested. I now find that the column configuration is preserved for the category sub-folders PROVIDED THAT “Show groups in contact list” is checked in Contacts Settings. I have not yet tried different configurations for each folder, I use “Apply Column Configuration to Other Folders” to copy my main configuration to all sub-folders.

There is a minor issue remaining. When selecting to display contacts by category (by selecting only a single category sub-folder), care must be taken not to deselect all folders. If the main “Contacts” folder and all the sub-folders are deselected simultaneously, the right panel correctly displays “This folder contains no items …”. If a folder is then selected, its contents are not shown - the same message is displayed. It is necessary to restart the application to recover.

I have updated to V6.0.20.154 and my behaviour is very similar to that of Ken posted 2 days ago. The process I use to set my custom column configuration is exactly the same but, even if I select ‘Show groups in contact list’ in the contacts settings, the configuration for all subfolders other than the main ‘Contacts’ folder always reverts back to the default view upon a restart of the client

I can also echo the behaviour that Ken describes in his last paragraph, a minor irritation, but a defect none the less.  

I am happy to provide some screen shots, but not sure what extra value that would offer.  If you want me to collect a video showing the complete interaction, I am happy to do that and PM it to you.

 

Hi,

the only situation when the columns configuration wouldn’t get saved is a problem with eM Client closing so please Exit eM Client and open Task Manager to see if the MailClient.exe process is still running. If it is, run the tool available from http://www.emclient.com/tools/emstackdump.exe and send the log which it generates to Paul at mcgregor@emclient.com. Thanks. 

I have checked carefully, and after I close emClient there are no residual processes.  However, when I restart the column configuration for all subfolders has reverted to the default, so perhaps the wrong data is being written to the saved configuration. 

Hi again,

As I explained, my issue with lost column configuration seemed to have been cured after upgrading to the latest version.  Unfortunately, the cure was only temporary and the problem has now returned.  All sub-folders revert to the default columns when the application is closed and restarted.  
I checked with Task Manager and the MailClient.exe process definitely shuts down when I close the application.

Regards, Ken

Interested that others have found the same problem.  I’ve just updated to 6.0.20154.0.  Immediately on opening emClient with this version the columns in Contacts were set to the custom columns that I had set up with the previous version.  So it looks like the column configuration was being saved, but not used when emClient opened!  In any event I’m pleased that it’s been fixed and hope the others can confirm this too. Thanks.

I am running 6.0.20154.0 and only the main ‘Contacts’ folder retains the custom configuration.   All other sub folders revert to default 

Hi, do you think it would be possible to make a screenshot of the issue?

Thank you,
Paul.

I have posted a videofile at https://drive.google.com/folderview?id=0B4DNWFPM8TF9NnVxTVdKdWk1UTA&usp=sharing illustrating the problem.

Malcolm

Hi, thank you for the video response, it was very helpful. Can you please try checking, once you exit the application, the task manager if eM client is really turned off when you click on exit?

Just look for an item “MailClient” in the task manager, once it’s turned off.

Thank you,
Paul.

Paul,

I have double checked using Process Explorer, and when I exit emClient, MailClient definitely terminates.

Hi again, this is really troubling us as this issue should be already solved. For resolving this issue, we could use your database files so it would be great if you could go to your local folder > app data > roaming, and archive the contents of eM Client folder, you can exclude your mail_data and mail_fti files.

If you could send the archive to my email with a reference link to this forum topic it would be great, so we can do some further testing (mcgregor@emclient.com).

Thank you, sorry for the inconvenience,
Paul.

Paul,

The requested folder is on its way

Malcolm

Hi, thank you for the received data, I’m forwarding this issue to the developers and I’ll keep you posted on possible solution.

Thank you,
Paul.