Can't sign in to GMail

I have just bought version 8 and am unable to connect with gmail. My btinternet accounts worked perfectly. I have checked all the account settings and they are correct. Idid have an issue with contacts and performed a repair. It came back and on the advice of Support baked up and saved. That did not work.

I have looked at this from every angle over the past 4 days to no avail. Support haven’t got back to me either since the first reply. I am hoping that someone could point out something simple that I might have missed. Thanks in advance.

Sometimes the easiest solution is to just remove the email account from eM Client, then add it back again.

Before doing that, make a backup using Menu > Backup.

Thanks for the reply. That is exactly what I did and I’m afraid that it didn’t work. Version 7 worked perfectly and i would have expected the transition to 8 to be seamless.

One peculiarity is that my activation key is exactly the same as the one I had after purchasing v7 five years ago. As i have said I really have tried everything to get it working. After doing the backup and re-adding the account, which did not work, I deactivated and reactivated eMClient, which also did not work.

When you add Your Gmail account do you get the browser open and the Google “Allow Access” window appear near the end of the setup wizard, to grant access to your Gmail account ?

Sometimes the browser doesn’t always come “Forward” and you have to toggle / tab around to see the Google / Gmail allow access screen appear.

Thank you. Yes I have had the Allow Access window including the Google alerts and went on the Google prefs to check that it was filed.

I did think that it was an AVG issue and went in the AVG prefs to add eMClient to the list of allowed apps.

I have looked up the Gmail settings and checked they are correct. Although I am not sure if I have the right security policy settings.

Every time I launch eMC I get a Can’t log in to account notice.

The BT accounts work fine so am wondering if there is a password issue?

Something you could try:

Remove the Gmail account from eM Client.

Go to your Google Settings and revoke the eM Client access.

Back in eM Client add the account again using Automatic Setup.

1 Like

Well I did that twice and it has not worked. I just wish that support would get in touch as I really have run out of ideas. Thanks for the idea though.

Support generally do not work on the weekends. I will look at your ticket tomorrow and see if there is anything further I can suggest.

In the mean-time, check your IMAP security policy setting. The port should be 993 and the policy Use SSL/TLS on special port (legacy)

Also, go to Menu > Help > License and see if it indicates a Pro License is activated, rather than a Free License.


Thanks. I didn’t realise. How thoughtless. Everyone needs the weekend off.

Those are the settings I am using and the Pro License is present.


When I deactivate AVG I can connect to gmail. However when I shut eMC down restart AVG and start it up again I still can’t connect. I have Allowed eMC in AVG. Not quite sure what to do next.

I would suggest to contact AVG technical support either via their Community forum AVG Support Community | User Forum for All AVG products Or via Official AVG Technical Support Request Form

1 Like

Interestingly I have found that if I disable the scan of incoming emails and then reinstate it eMC can receive emails from gmail until it is closed down and then restarted and then it does not receive emails from gmail. It is clear that there have been reports of this problem between AVG and eMC in previous threads from the middle of last year, So why has this issue remained. I certainly had no issues with version 7.

If eM Client works correctly with AVG disabled, then you will need to configure AVG to allow eM Client to access the Internet. Those links @cyberzork gave are a good start.

Well I have just spent two hours with an AVG support representative exploring the issue on remote. All the settings that can be done have been. I might point out that my research has located a number of posts when Version 8 came out with customers with exactly the same issue. Which leads me to wonder why this has not been addressed or why there is no answer to solve this issue. It might be important to add that this issue did not happen with eMC version 7 and I am now pondering my decision to upgrade to version 8.

One such example from July 2020

My firewall is very similar. With some applications, the application version update does not affect it’s access to the Internet, but with others, the firewall blocks them. I have been discussing for years with the firewall provider about them fixing this.

Hope it doesn’t take you that long with AVG.

Why in that case would it not affect version 7? I have even uninstalled and reinstalled. However the flaw in that thinking is you have to import your back up and have all the same settings, of which one might be the issue. Given that this is a known issue I am wondering why this has not been resolved. It doesn’t seem fair to let the customer find out for themselves.
I might try without the backup. Could I remove all the backup info and what am I looking for as the eMClient folder is not intuitive?

Tried the eMC without backup and still did not work, so had to use the back up in the end. I am rather cross with myself that I did not back up before I upgraded to v8, which probably means that I will not be able to revert back to v7 if it does not recognise a v8 backup. It is annoying as so many folders of archived emails are now difficult to access.

EDIT: Having just upgraded AVG recently to Ultimate I turned on the VPN. Blow me down if the emails didn’t start appearing!?*!!! What an earth does this mean. I have yet to confirm. Is this because I enabled encryption? Will it still work tomorrow??

It seems that the VPN being turned on allows the gmail content to be downloaded. It is still working. It was the last thing I thought about! I wonder if this will work for anyone else who encounters this issue.

That is interesting. Usually it is the other way around.

Who is your Internet provider David?

Yes! I find this hard to understand, glad as I am. AVG Chrome. Which might explain it. I had a weird exception when I first enabled v8 and eMClient got “Blacklisted” until I made it a trusted app. I am guess that there is something in the email communication protocol that AVG didn’t like, so didn’t allow it. However, with VPN on the issue became irrelevant, as whatever it was could not be communicated with a third party.

Listen to me! It almost sounds like I know what I am talking about.

1 Like