Can't send E-mails but can receive them

I can receive E-mails, but everything I try to send gets stuck in my outbox.

Hi, are you getting any error messages? If so, can you post here a screenshot?

The screenshot won’t post, but the error message I’m getting is as follows

[SMPT] An attempt to connect to jswalker1963@comcast.net failed. This could be caused by temporary server unavailability or incorrect settings. Do you want to check the settings?

I get the same message for both my accounts. I have not changed any of my original settings. Again, I receive E-mails but outgoing ones hang up in my outbox.

I also have numerous messages in my log, including this one numerous times:

(My Email address) [SMPT] mailexceptions.socketexception: connect failed with reason:
"An attempt was made to access a socket in a way forbidden by its access permissions 68.87.26.155:25

Also, I have gone through the diagnostics, and it comes up with

“Server not responding”

I click on fix, and it goes through several settings, and then shows as fixed. But it isn’t. The error message comes up again, and when I go through the diagnostics it does the exact same process every time, shows as fixed, etc etc.

I found a topic where another user was having the same problems, and his fix fixed mine as well.

Resolved.

Jeff, please post whatever fixed your issue here !

Thanks

Under my comcast accounts, under SMTP

Changed the port to 465
Changed the Security policy to "Use SSL/TLS on special port (legacy)

And that fixed it.

Maybe you are using DEMO version, which is Expired.

Thanks Jeff,

Your settings helped me fix my problem as well.

Fahd.

Thank you so much!!  Still works after all this time.  I have two comcast accounts and could not get eM Client to send out mail, either, but changed the port to 465 and it works.  Thanks for posting your solution… you helped at least one person…Oops, two people!  :)

Alas this did not resolve the issue for me - I have tried all policy settings and all ports; 25, 465 and 587  and still it fails and won’t be fixed.  Oddly a few says ago , I sent an email without a problem, so I know it can do it sometimes!  
Using em Client version 7.0.27943.0, also tied turning off virus protection but that did not help either. 

I have the same issue and made the suggested changes and it still doesn’t work… very frustrating! DOES ANYONE HAVE ANY OTHER IDEAS?

One option is to remove the account and add it again. See if that makes any difference.