can't add google account with 2 factor authentication on win 10

worked on win 7, receive this on last step:

You’ve reached this page because we have detected that Javascript is disabled in your browser. The page you attempted to load cannot display properly if scripts are disabled.
Please enable scripts and retry the operation or go back in your browser.

Hello Jay,
unfortunately this is an issue we know about at the moment and are trying to find solution for.
Check in Javascript is really enabled in Internet Explorer.
If it is, please try logging into your gmail account through webmail using Internet Explorer.
Try removing eM Client either from your connected apps (…) or from your App passwords (…) and then logging into eM Client, giving it the permission anew.
This has managed to help some users, but it might not work.
I’m sorry for the inconvenience this issue is causing.

Best regards,

Was able to login to gmail on all browsers (win 10 has a new browser, it’s not IE anymore).  Anyway, got it to work by creating an app specific password in google and using that.  The 2 factor screen never worked on this pc.

same Problem…again fail with 2 factor Auth… what should we do? I need it…!!

Windows 10 x64

Same config in the office still working…

Since we still didn’t determine what is causing the Javascript issue, I can suggest trying some workarounds…

First workaround that seemed to help are these steps:

  1. Change your google account so that two-factor verification is disabled. You can let google save your 2f settings when you disable it.
  2. Remove and re-add the account to EM.
  3. Let EM re-sync everything
  4. Turn two-factor back on.

The second workaround is setting IE 11 security level mode to medium and disabling protected mode in security tab worked for some users.

Another workaround that seemed to work for others is to open Internet Explorer and log in to with your Google Apps account. Then go back to emClient and log in again.

I realize these are not ideal solutions, but just something to try to get your account working until we find a proper fix.

Best regards,

not succeeded, the incorporated browser insists to use the main password, as a 2 step log in!

Unfortunately Olivia’s responses here, whilst offering helpful workarounds that might work in some cases, does not address the issue. This has been broken for months or weeks depending on how generous you want to be regarding emClient’s veracity. But there has been no real communication from the team to keep us posted on their efforts to fix it (if indeed there are any). And they continue to advertise functionality that doesn’t exist.

The lack of customer care has now made me think that even if it did get fixed, I’m not sure I could trust the team to support the product. I’ve paid hundreds of pounds for our licenses and consider this to be a severe breach of contract.

Hello Gary,
I realize that you are losing your trust in eM Client, but we figured out that the error is caused by Google’s discontinuation of oAuth support for Internet Explorer few weeks back (which was done without any information release from google’s side).
We have the workaround almost ready and will push it as an update soon.
Thank you for your patience.


Olivia, I really genuinely appreciate you replying. Just snippets of information like this every now again makes we paying customers feel like we’re being listened to rather than ignored.

I have to say, though, I still don’t understand why the issue seems to affect emClient but NONE of your competitors using OAuth. Maybe you just didn’t get the memo…And Internet Explorer is not my default browser, so presumably emClient is forcibly using IE as the authentication window rather than calling a default browser window.

Hi Gary,
the reason why it influenced only us is because we are using the Internet Explorer core for different parts of our app (for example viewing emails, text editors, loading web content etc all make use of it). Other Clients probably use different solutions (as there really was no memo from Google). It doesn’t matter what your default browser is.

As I mentioned, the workaround for v6 should be done soon, and these problems concerning IE will be removed all together in v7, because we exchanged the IE core with WebKit, which is based on Chromium (so no more surprises from Google in the future, hopefully).


It’s great to hear that you’re moving to WebKit! And I’m very much looking forward to using eM Client again when I can actually set up my Google accounts in it.

Since a lot of people who were looking at eM Client have uninstalled due to a lack of progress on this issue, it may be tough to get the word out.  

I would respectfully suggest you send an email to everyone you have an address for to let them know the problem has been resolved and a new version is available.  I, for one, would take another look but hardly have the time to continually check your site to see if there is a new version available (and, for that matter, the means - it is just about impossible short of downloading to tell what version you have available).

Hi everyone,
the new update that fixes the Google OAuth issue is out.
Read about it in the newest announcement:…


Worked perfectly tonight on my Win 10 pc.  Thanks.