Cannot send mail

Since updating to Ver. 5.0, I am unable to send mail. Everything justs sits in the outbox. I receive mail with no problem.

Hi,

Wich e-mail account do you use in em client 5(gmail,hotmail,yahoo),it seems to be that there is a problem with the smtp server wich is sending your mails,you can check the settings to tab tools and then tab accounts select your account and tab on smtp server.
Do you have also received an update from em client from version:
5.0.17595.0 with inside some bugfixes,mayby this problem is fixed with this update.
I have received today the update(NL)you can manually check for updates to go to help and tab on check for updates.

Kindly regards,Geert

Thomas - are you getting any error messages? If so, can you please post here a screenshot? You can also send us your SMTP logs - it would help us a lot.

I am paraphrasing the error message… Connection failed. [SMTP] Attempt made to connect to pt4707@comcast.net failed. This could be due to temporary unavailability of server or incorrect settings. Do you want to check the settings.

Following is a set of entries from the log:
3:21:48 PM Online state: changed to online with reason NetworkAvailability
3:21:48 PM pt4707@comcast.net [SMTP] Connecting: To pt4707@comcast.net
3:22:09 PM pt4707@comcast.net [SMTP] MailExceptions.SocketException: Connect failed with reason:
3:22:09 PM “An attempt was made to access a socket in a way forbidden by its access permissions 68.87.26.155:25”
3:22:09 PM at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
3:22:09 PM at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
3:22:09 PM at MailClient.Commands.Command.Process(WorkerStatus status)
3:22:09 PM pt4707@comcast.net [POP3] Connecting: To pt4707@comcast.net
3:22:09 PM pt4707@comcast.net [POP3] Connected: To pt4707@comcast.net
3:22:10 PM pt4707@comcast.net [POP3] Downloading messages: From pt4707@comcast.net
3:22:11 PM pt4707@comcast.net [POP3] Disconnected: From pt4707@comcast.net
3:22:11 PM pt4707@comcast.net [POP3] Disconnected: Done
3:32:47 PM pt4707@comcast.net [SMTP] Connecting: To pt4707@comcast.net
3:33:08 PM pt4707@comcast.net [SMTP] MailExceptions.SocketException: Connect failed with reason:
3:33:08 PM “An attempt was made to access a socket in a way forbidden by its access permissions 68.87.26.155:25”
3:33:08 PM at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
3:33:08 PM at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
3:33:08 PM at MailClient.Commands.Command.Process(WorkerStatus status)

As mentioned earlier, everything was fine until I downloaded the update. Even when I run diagnostics and it says it’s fixed, still no ability to send. I have also tried different authentication methods.

Try to make an exception for eM Client in your Antivirus/Firewall and let me know if it helps.

In Norton Antivirus, I changed the setting from “auto” to “allow”. Windows firewall is managed by Norton, but I did put in an exception in the outbound rules of windows firewall. None of these changes did anything. No e-mails are being sent

Update…I found out that Comcast changed the port from 25 to 465, but SMTP still does not work even after changing port. I am getting a new error message now with the port change:

11:51:54 PM Online state: changed to online with reason NetworkAvailability
11:51:54 PM pt4707@comcast.net [SMTP] Connecting: To pt4707@comcast.net
11:52:24 PM pt4707@comcast.net [SMTP] MailExceptions.SocketException: Connect failed with reason:
11:52:24 PM “Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”
11:52:24 PM at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
11:52:24 PM at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
11:52:24 PM at MailClient.Commands.Command.Process(WorkerStatus status)

In that case please change your Security policy in the tab SMTP to “Use SSL/TLS on special port (Legacy)”. It should help.

On Sunday, I played around and figured that out. In addition, though, server authentication is also required. You need to use identity credentials. I’m glad this is resolved. Just wish it could have happened faster.

On another note, a suggestion for the next upgrade unless I’m somehow missing it.
It would be nice to be able to set a font color for replies to messages rather than having to always change the color when replying.

You can create a template for all the replies which will contain a font color info.

Found it and did it. I think that covers everything for now. Thanks for the help.

I forgot to add that again, unless I’m missing something, I notice when using the template, it also changes the color of the original addressee’s information. Any way around this?

If the original message has specified the font color, eM Client will not overwrite it.