Cannot connect to O365 with Multi Factor enabled

Good morning,

A few days ago my work enabled and required MFA (Multi Factor Authentication) using AIM (Azure Identity Manager) services. I have deleted and tried re-adding my Office 365 email account back into eMClient, but it fails. I don’t get any type of prompt for the MFA portion. I have tried both automatic and manual setup with the same result. I am on version 8 of eMClient.

Any direction would be appreciated since I can no longer get my work email through emClient.

FWIW, I also use MailBird, and had no issue setting my work account back up with MFA in MailBird.

Thank you in advance for your any assistance.

I will also add that AIM MFA does not allow the use of an ‘app password’ like the base O365 MultiFactor, so using an app password is not an option. I need to actually get the MFA promp to appear like I do in Outlook or MailBird.

Thanks again for any thoughts or assistance.

Good morning,

Following up to see if there was any information about this, or when eMClient will start supporting MultiFactor Authentication from Microsoft?

Thank you.

It’s same for me :frowning:
The Office MFA don’t work with EMClient

Any updates on this for us, please?

Is there any updates on this? I downloaded the free version to try before buying but my accounts have 2FA and I can’t add them.

Try following the instructions in this article.

1 Like

Hi everyone,
to make oAuth/MFA login work for eM Client, it needs to be allowed in your system.
Please try following the steps in this article:

This solution worked for me! Thank you SO much for providing this info. I have followed the simple steps and confirmed Microsoft MFA via Azure is working and allowing me access to my work email again.

Thank you again, and have a great day!

Acknowledging this post as well. It is the same solution @Hope777 provided.

Thank you and have a wonderful day!

1 Like

emclient does not work for me with office365. I have installed the registry keys. The automatic setup does not work. “The correct settings could not be determined”
When I try manually I have no luck either.
Thanks for your help

That probably means that your server is not providing autodiscover information that eM Client needs.

When you setup manually, what error do you get?

ich wähle Exchange aus
xxx[Exchange Web Services] MailClient.Accounts.ConnectionException: Couldn’t get server version.
MailClient.Accounts.ConnectionException: Invalid host or path address.

Username und Passwort

xxx [Exchange Web Services] MailClient.Accounts.AuthenticationAbortedException: Authentication aborted

when I set up with Outlook, it works. But that is not the goal.

What happens if you remove the Exchange account from eM Client, then go to Menu > File > Import > Microsoft Outlook, and import the account from your Outlook settings?


the password prompt always appears, this is never recognized despite the correct PW

If you use the email address for both the address and username when setting up manually, does that make any difference?

Or make sure that the login name in the existing settings is the email address?

No, emailadress and UPN are the same

I don’t know what to suggest except that if you have tried everything, including the app password and not the account password, then if you have a Pro License, open a support ticket with eM Client.

OK, thanks for your help.
I don’t have a license yet, I am in the evaluation process. I will wait and see.