Calendar Row Height White Space V8

I just downloaded version 8. My problem is that the text in my calendar entries has so much white space that it takes up a whole hour. I went to Appearance / Lists / Row Dimensions and set them all at the smallest possible which was great for my email messages but did nothing for the calendar. I have my font set at Times New Roman 9. I really need my information to fit in 30 minutes or less as I have busy workdays with calls and meetings etc. What is the magic fix guys??

Hi, To add to this - for me the date section on each day is too deep (fat) which means that I can only see 2x entries per day in month view. The date bar showing Mon, Tue, Wed etc could be half the height and the bar showing “Jul 6 7 8 9” etc could also be made a lot narrower. This would allow an extra 2 appointments to be visible without having to click “2 more events”.

We need a way to change these settings too. We could also do with an option to show the month in full rather than the next 5 weeks. In V7 it showed the whole month. That’s kind of the point of “Month View”. What I have is “Next 5 weeks view” :frowning:

Is this the same issue I’m having? Before, I could have an event at 9:00 and another at 9:30, stacked on top of each other. Now, they’re set to either side because for some reason the event colour block is now bigger than half an hour! I’ve tried changing granularity in settings, but it’s stuck at being too big!

If this doesn’t change, I’ll have to go back to v.7.

I have the same problem with V8, important appointment information does not fit the appointment box anymore. Is it possyble to remove the timestamp in the appointmentbox?