Calendar granularity

Since the new update, calendar granularity has changed to 30 minutes and I can’t change the grid to 15 minutes.

First of all, calendar can’t show whole 24 h in day/week view using 15/30 minutes granularity. This bug has been introoduced with version 8.2.xxxx

Try this:

You get this:


But it also changes if you zoom in or out of the calendar view. At the biggest magnification, there is nothing, Just 4 hours in one block.


At the smallest magnification it will be 5 minutes.


Already tried that, it never gives the option to have an hour divided in quarters, whatever zoom level I use.

How are you zooming?

I use Ctrl + mouse wheel.

FWIW, to zoom on month view, you first need to click on a day, where as in week or day views you do not need to select anything first.


Before the latest update, every hour would be divided into clickable quarters. I had the weekly view 8:00 - 22:00 with a granularity of 15 minutes for years. Since the latest version, this no longer works. Now I have to click either the whole or half hour and manually set it to a quarter past or to in the event menu.

It was a similar view like this:

As of the latest version, you can’t set the calendar to such a zoom and granularity combination.

Latest version means what?

My screenshots are from yesterday’s release 8.2.1237.

I have version 8.2.1237.

Same problem -
if I set to 15 minutes granularity I can only view 6 hrs at a time,
if I set to 30 minutes I can only view 12 hrs at a time (without scrolling up and down)
previsously I could set to 15 minutres granularity and view all 24 hrs
version 8.2.1237 installed today

It is strange. I can set granularity to 15 minutes and I can see the clickable quarters. (screenshot)
But I can not see whole 24 hour of calendar.
I think it may relate to screen resolution and zoom level setting in Windows.
It works fine on my computers:
computer1: 1920x1080 @ 100%
computer2: 3840x2160 @ 150%

I’m on 1920x1080 and the calendar layout is all messed up.

I figured out what’s wrong. In version 7, the row height (Appearance > Lists) was 23 pixels. In version 8, the row height is more than 30 pixels. Even though version 8 makes it seem like you can reduce the row height, you really can’t - it’s always more than 30 pixels. That’s why none of us can get the calendar to display properly - because the programmers made the row height too tall, and we can’t adjust to bring it down to 23 pixels like in version 7. The only solution is to stay with version 7.

Cool, thanks for the heads up! Is there any way to roll back to 7?

EDIT: Found it. For those also wanting to roll back:

Older versions: Release History | eM Client

Rollback instructions:

I tried on my computer, but even at 3840x2160 @ 100% you cannot get 24 hours no matter what zoom level.

And who wants to use 100% at that resolution anyway?

Hi Gary,
please, can You explain it in more details what do you mean by it?
I don’t understand if you mean there is a bug in EMC or there is none…

No I think not a bug, but maybe a limit.

At 2160 vertical pixels, there isn’t enough space to display the whole 24 hours.

So, I’ve been messing around even more with the granularity.

When setting a granularity of 15 minutes, you can’t set a higher range than 10 hours. Setting any higher range gives no change in the size of event markers and zoom.
Before the update, I had event markers of a size you get when setting granularity 30 minutes and a range of 18 hours now.

Is this change intentional or a bug?

Prej, you are rigth, same here.
Gary, somthing went wrong here:

Release history
History of all eM Client versions ever released
| 8.2.1193.0
| Wednesday, March 24, 2021
| eM Client 8.2
| …
| - Visual tweaks and rewritten large DPI/small monitors logic in Calendar
| …
| 8.1.1060.0
| Thursday, January 28, 2021

Exactly! As Prej said: when selected 15 min granularity, the calendar range value change doesn’t make any change in the view range.
It is usual in software, that changing an option value does change the output view. If not, it doesn’t work.
It is a bug since ver 8.2.xxxx
The calendar view was working fine till 8.1.xxxx
I have chosen 24 hour view with 15 min granularity and it worked right. I could enter the event in clickable quarter hours.

I agree with Vladimir
I have the same settings 24 hour view with 15 min granularity. On 8.1xxx it works fine

On the 24 view setting is overwritten since the granulartiy lines seem to have a large minimal distance

This distance does not change if you change the size of the window, but the visible time interval changess
To the em staff: It would be nice if this bug could be fixed in a future release. Thank you!