Calendar event with location crashes client

When I try and edit a calendar entry in my Google calendar that has the location field filled in, it crashes the client. The same thing happens when a reminder for such an event pops up. Once the client crashes, the database gets corrupted and then I have to delete the local db in order to restart the client. This is making the calendar portion of the client unusable. I have tried deleting old meeting entries and creating new ones but this has not helped. Please advice!

You might try right-clicking on the problem calendar, select “Properties” and click on “Repair”.  If this doesn’t work, I would delete the account and add it again.  Since Gmail accounts in eM Client are automatically setup as IMAP, it will resync everything after reentering the account.

When I repair the calendar, the client crashes. I have tried re-adding the google calendar many time. It doesn’t solve the problem. Is anyone looking into this bug?

I really meant reenter the entire Gmail account.

I would also suggest if reentering the account information does not work, start with a fresh database and then reenter the account info.  To do this:

1.  Close eM Client
2.  Navigate to c:\users[user_name]\AppData\Roaming
3.  Rename the eM Client folder eM Client.old
4.  Restart eM Client

This will create a new, fresh database.  Reenter the account information and allow it to sync.

This isn’t typical behavior and it doesn’t seem like a bug to me, more likely a corrupt database.

I just tried this and got the same result - client crashed. I have tried using a new db many times, it never solves the prob. It surely looks like a bug to me. This is making the calendar completely unusable for me.

If it was a bug, there would be many reports and there aren’t. May just be a particular calendar item with something strange.

If you’re a pro user, you might want to submit a support ticket.

It is happening with any entry that has a location field populated. Took me a while to figure this out. I am not a pro user. Honestly, this issue is the main reason why I have not upgraded my account. I am surprised there is such lack of support for bugs in these forums.

I use Gmail, I have events with locations and I have no crashes, so I’m still not sure it’s a bug.
This forum is primarily a user forum for free users.  Although eM Client does participate, it is inconsistent.  You can purchase the product with a 30 day gurantee if they are unable to solve your issue.

Interesting. Not sure why this is an issue on my laptop. I have re-installed em also, the problem has still continued.

When you reinstall eM Client make sure you delete the data directory as well. The uninstall routine does not and this way you will have a complete fresh install.

One thing you might try, is to install the latest version available at

I downloaded the app again and installed it after removing the eM Client directory. It looks like the issue is not showing up anymore. Keeping fingers crossed. 

Thanks for the help with this!