CalDAV Calendar not syncing: TLS alert: 'IllegalParameter'

Hello everyone,

I’m using em Client for my email (IMAP) and calendar and contacts (DAV) with a mailbox.org account.

Since a while i see that the calendar won’t sync with this message in the log:

      ---> System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception.

      ---> System.Security.Authentication.AuthenticationException: Authentication failed because the remote party sent a TLS alert: 'IllegalParameter'.

Any ideas?

Since a short while, I have the same problem as described above.
Closing the client and reopening it solves the problem, but after a few minutes, the failure is back and the CalDAV/CardDAV-Sync stopps again.
IMAP/SMTP is not affected.

My client is a IceWarp Desktop Client (a labeled eMClient), Version 9.2.1886, used on a Windows 11 Pro 64 Bit system.
It connects to an IceWarp Server (13.0.x) and a Kerio Connect (9.4.2 and 10.x) and the problem exists with both servers.
Sometimes only one of them is affected, sometimes both.

A complete reinstall of eMClient doesn’t solve the problem.
Very strange behaviour.
Does anyone else have the same problem?

Hi,

I had posted a similar case - still waiting for a solution, though:

For unknown reasons my emClient calendar does not synchronize anymore with external calendars, i.e. my GMX account (inbound).
Outbound (emClient > GMX account) is still synchronizing ok.
External calendars are (1) my GMX account and (2) my Android smartphone
As sync-tool on my smartphone I use “Opensync”

Any suggestions?!

This error for the TLS alert on illegal parameter is because of certain versions of OpenSSL on the server which contain a bug in one of the ciphers. Ciphers are selected at random, so sometimes it works, sometimes it fails. But it appears to only happen when you have enabled TLS 1.3 in your OS. Please disable TLS 1.3 again.

Hi Gary,

thanks for the hint.
I have disabled TLS 1.3 in the configuration of the mail servers (Kerio Connect and Icewarp) and in my windows. Unfortunately that doesn’t solve the problem.

The following exceptions in caldav/carddav still apear.

14:24:08.291|060| Exception: MailClient.Accounts.ConnectionException: The SSL connection could not be established, see inner exception.
14:24:08.353|060| —> System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception.
14:24:08.354|060| —> System.Security.Authentication.AuthenticationException: Authentication failed because the remote party sent a TLS alert: ‘IllegalParameter’.

It is possible to reset the failure by opening the settings of the failed calendar and activating the page “access control”. This reconnects the calendar with the server and the sync starts.
You have to do that separately for all failed accounts.
This solves the problem for a while. After an undefined timespan the exceptions occure again.

Do you have another idea?
Thanks in advance.