CalDAV and ownCloud: performance is bad

I’m running ownCloud on my Synology DS 212+ with using calender und contacts via CalDAV and CardDAV in eMClient 5.0.
Contacts works fine. But every time I have a look on calender it seems to syncronize new with the server. First I can see all the calender entrys, then all are gone and then they come new on the screen. Then they disappear again und are shown again. So it can take up to 2 or 3 minutes that I can work with the calender. Do you have any idea?

Hello,

do you have newest version of ownCloud?

regards
Jan

Hi Jan,

yes, I do. 5.0.10 is installed.

regards
Wolfgang

In this case I will need to see your logs.

Tools - Settings - advanced, check CalDAV/CardDAV under your account, apply and restart eM Client.

follow same steps which leads to your issue and from same “advanced” windows send logs… to galis@emclient.com

please add this topic’s URL also: https://discourse.emclient.com/emclient/to…

after this you can turn logging off.

regards
Jan

Hi Jan,

sorry for my late answer - i’ve been in holiday.

I will send you the log right know.

One thing I forgot to write till now:
When I start the calendar, sometimes I can see some entrys, sometimes not.

When I started the log (view: month), the calendar was empty. Then it tooks some time, the progress bar was running and finals finished. The total count was “0”. Then, some seconds later the calendar entries where shown, total count was “12”. But I could’nt see the the system is still working.

Changing the view to week, I could see 2 entrys, then their was gone. In the folliwing the same the starting with the month view: the progress bar was running … and after waiting (total count was “0”) - o wonder, 2 entries where shown total count was 2. Again: I could’nt see the the system is still working.

While i was writng this replay the view has been refresh automaticly - I thing it was the 10 minute interfal for automatic “send und receive”: Clean calendar, …

regards
Wolfgang

Hello,

I have sent logs to my colleague, I will respond you to email when I will know more.

for other users I will post here solution or more information when I will know more.

regards
Jan

@wolfgang:
this a known problem, i have it too. I found a workaround, see if it can help you:

https://discourse.emclient.com/emclient/to…

Hi Jan,
in the meantime i tried thunderbird to access the calandars via caldav. And I have to say: I don’t have the problems like using emClient. So I think it is a technical problem in emClient.

Regards,
Wolfgang

@irisquota:
Thanks for your hint. I tried, but emClient seems to make a resynchronisation as well as. The search-list is being rebuild again.

If any of you would also like to see the “delayed send” feature added to emClient, please vote for Delayed Send here:
https://discourse.emclient.com/emclient/to…

Have the same issue.

Sync with my android phone works perfect. Also Thunderbird is fine, but eM Client sucks…very annoying. especially as it looks perfect for my needs.

So I’m very intressted in a solution…

@wolfgang / @ian:

I’m sorry it couldn’t help you.

The strange thing is that my workaround is starting to behave oddly also for me: i have about ten saved searches, on ‘Categories’ field, and for just two of them emClient forces the resync. The others are ok (no resync).

Even deleting and recreating them doesn’t help.

Very strange.

I will post here what I have received from my colleague who is responsible for iCloud implementation:

"Hello,

This issue seems to be caused by ownCloud.
The server exhibits incorrect behaviour when returning version information for the events.

In more technical detail:
a) PROPFIND command returns different eTag than subsequent calendar multiget REPORT command. The items weren’t changed in the meantime and later PROPFIND returns same eTags as the first one.
b) This leads eM Client to think the item is different every time and to re-download the items.

Either a newer version of ownCloud might fix this or the issue should be reported to ownCloud.

Should you need any more technical detail, let us know."

With best regards
Jan

Hi Jan,

sorry, i can’t understand your answer.

I don’t have any problems using Thunerbird with Lightning or iOS-Devices with iOS 6 or iOS 7. But I have problems using emClient.

I did pay money for emClient - and it doesn’t work. I don’t have to pay money for Lightning and it works.

Please check again.

Thanks in advance,

Wolfgang

See the next answer, please.

Hello,

You never told me that you are pro user. Can I ask you why you are not using paid support? You would get there faster response and my colleagues there are more experienced.

Anyway this is really caused by ownCloud as I have described before. I understand that this is not useful for you and you care only about working it, but eM Client is innocent in this.

with regards
Jan

For other readers that might stumble over this thread, just like I did this morning: I’ve had the very same problem with OwnCloud 5.x. Updating OwnCloud to version 6 fixed the issue for me.