Bug with in-cell editing control

When the Tool>Settings>Appearance>Lists>Allow in-cell editing is turned OFF, then a new task cannot be added by typing in the top line provided for that. It would seem if you are disabling that feature, then you shouldn’t show the line at all rather than the message “click to add a new item” which then does not work.

I suggest always allowing adding a new item through the top line and use the setting to allow/disallow editing existing items.

I also suggest that if in-cell editing is turned off, clicking on a cell in an existing task doesn’t change the background. Leave the entire line with the background of selected items as a clue that you cannot edit that cell.