BUG: Signature when forwarding not inserted at the end

Using version 9.2.1713 on windows 11, I set up my signature as follows:
image

The important part is the signature position: it is set to “after quoted text”. As expected the signature is inserted at the very end of the mail for

  1. new mails
  2. replies to mails

:beetle: But here is the bug:
for all my forwarded mails, the signature is inserted BEFORE the quoted text.

I already tried :

  • switching it to “before quoted text”, saving the settings, exiting the settings window, re-open the settings window and setting it again back to “after quoted text”. But to no avail.
  • switching it to “before quoted text”, saving the settings, exiting the settings window, exiting emClient, restart emClient, re-open the settings window and setting it again back to “after quoted text”. But to no avail.

(I’m pretty sure, the behaviour wasn’t like this a couple of weeks ago)

Is it just me or is this a bug in the current version?