Bug report: calender bug after connecting 2nd screen

Just witnessed a strange behaviour I experienced for the first time:

I’m under Windows 11 and use a Lenovo x1 Tablet, 3. Gen.

I recently connected a 2nd display for the first time and added the 2nd screen as additional screen space.

After I disconnected the screen and worked on the tablet (screen) alone, I wanted to create a calender entry. This didn’t work: when going to the tasks overview, I could see the pop-up window, but it was nowhere to be seen on the tablet screen.

I did correctly assume that this was related to the recently used 2nd screen (where I had emclient windows open both on the tablet and 2nd screen).

So I reconnected the 2nd screen - and the calender entry pop-up window immediately appeared on the 2nd screen when trying to create a new entry. Moving this window back to the original tablet screen before quitting emclient solved the problem.

However: emclient remembering a 2nd screen and still trying to open pop-up windows on it even though it is not connected anymore is clearly a bug … so I hope this is the right place to share this observation.