Bug in program - email address is being truncated

A contact of mine has the email address cafletcher (at) telus.net.  When I reply to him, the ‘to’ field populates as “Tony Fletcher” ie. it is removing the “s” from telus. But when I look at the quoted message in the body it correctly shows it :

------ Original Message ------

From: “Tony Fletcher”

To: “Rob”

I can’t see any reason why the program would do this unless it’s a bug. Could you please investigate and fix. For the avoidance of any doubt I have replaced the @ symbol in the email with words.

Hello,
this is a rather curious issue, would you mind getting a test email or sending me one from this contact? I’d like an eml file of the original message and then when you try to reply, save the draft as eml as well. Send both of these to rust@emclient.com

Best regards,
Olivia

Done.

Hi Rob,
I looked at the header and mail source of the eml file, and the issue is actually the sender’s fault - he has the Reply-To field set up to to the different address:
___________________________
Reply-To: “Tony Fletcher” cafletcher (at) telu.net
From: “Tony Fletcher” cafletcher (at) telus.net

I’m not sure if it is a typo or if he does have a second address set up this way, but it’s hard-coded inside the message and is not an eM Client issue.

Best regards,
Olivia

Hi Olivia,

I have closely examined the source header and indeed you are correct!  My apologies for blaming your program.

I have alerted Tony but he will have to take that up with his mail account provider.

To prevent any confusion in the future it may be wise to delete this thread.

Rgds.

No problem, I’m glad the issue is sorted out now.
I will keep this thread here as solved in case someone has a similar problem in the future so they know where to search for the cause of this issue and not ask on eM forum again :slight_smile:

Best regards,
Olivia