Automatically encrypt e-mail (optional) if the recipients certificate (s/mime) is available

Even when the recipients certificate for e-mail encryption (s/mime) is available, i have to encrypt the mail manually by clicking on the lock icon in compose window.
I would prefer having an option to let e-mails encrypt automatically, when the recipients certificate is available.

Hi, you can do this by going to Tools > Settings > Mail > Certificates > Security profiles.
Create a security profile for your account and check the option “Require encryption”.

Hope this helps,

Hi Paul, 
I already tried this. But this only works, if you have all certs of all recipients available.
Sending fails, when the recipient’s cerficiate is not available.
So the idea was to have an additional (3.) option that says: “automatically encrypt if the recipient’s cert is available - if cert is not available, then do not encrypt”.
Currently I can just set (1.) “Require encryption: NO” or (2.) “Require encryption: YES”.
–> “Require encryption: YES” leads me to an error, when I don’t have recipient’s cert: "Cert not available. Message could not be sent. "

With a new (3.) option, messages would be encrypted, if the recipients cert is available. And not encrypted if the recipients cert is not available.

Hi, if you have the automatic encryption and the recipient does not have the certificate to decrypt the email you should be prompted if you really want to send the message unencrypted, does this not occur?
Can you please translate the error you’re seeing for me?

Thank you,

Hi Paul,
you are right. There’s no prompt if I would like to send unencrypted instead.

The error messages says:
Headline: “Certificate required for encryption.”
Text in the box: “For the following recipients no certificate for encryption is existent. … Message could not be sent.”


Hi again, do you have a certificate imported for the account you’re trying to send the email from?
Can you make a screenshot from your certificate settings in Tools > Settings > Mail > Certificates > Certificates?

Thank you,

Hi, yes, I have installed the my own cert. Here 2 screenshots:

Hi again, I’ve discussed this issue with the developers and I was told this is actually the intended behavior however we’re considering improving this for future releases so maybe the message I mentioned is shown when this situation occurs, but with the current setup you have to turn the encryption off manually after dismissing the error.

Thank you for understanding and sorry for the inconvenience,