Automatic set of "From" when reply ?

How to automatically set sender account A when replying to email send to my A account ?
Example: I have got email send to “me@mydomain.com”. When I reply I need the From is set to “me@mydomain.com”. And same for my other email accounts i.e. “meother@myotherdomain.com” etc… I should set it manually every reply now.

When you open an email, address used for sending the reply should be chosen automatically as you described.
Are you using any Aliases?

It doesn’t work.

I set all my email accounts to forward to my Gmail account. I use eMclient to fetch forwarded emails from gmail account. Is this the reason the automatic address chosing doesnt work ?

What email header field is used to set from account ?

Received email header:


    
    Delivered-To: nowak.petr@gmail.com
    Received: by 10.231.236.15 with SMTP id ki15csp60200ibb; Tue, 14 May 2013
     06:12:16 -0700 (PDT)
    X-Received: by 10.15.82.201 with SMTP id a49mr91390506eez.44.1368537136174;
     Tue, 14 May 2013 06:12:16 -0700 (PDT)
    Return-Path: <bounces>
    <br>
    Received: from lady.smtp.cz (lady.smtp.cz. [81.95.97.113]) by mx.google.com
    <br>
     with ESMTPS id x49si28990976eey.134.2013.05.14.06.12.15 for
    <br>
     <nowak.petr> (version=TLSv1 cipher=RC4-SHA bits=128/128); Tue, 14
    <br>
     May 2013 06:12:16 -0700 (PDT)
    <br>
    Received-SPF: softfail (google.com: domain of transitioning
    <br>
     bounces+411151-7519-facebook=pnowak.net@email.getsatisfaction.com does not
    <br>
     designate 81.95.97.113 as permitted sender) client-ip=81.95.97.113;
    <br>
    Authentication-Results: mx.google.com; spf=softfail (google.com: domain of
    <br>
     transitioning
    <br>
     bounces+411151-7519-facebook=pnowak.net@email.getsatisfaction.com does not
    <br>
     designate 81.95.97.113 as permitted sender)
    <br>
     smtp.mail=bounces+411151-7519-facebook=pnowak.net@email.getsatisfaction.com;
    <br>
     dkim=pass header.i=@email.getsatisfaction.com
    <br>
    Received: by lady.smtp.cz (Postfix, from userid 64020) id 524136A002; Tue, 14
    <br>
     May 2013 15:12:15 +0200 (CEST)
    <br>
    X-Spam-Checker-Version: SpamAssassin 3.2.5-a24 (2008-06-10) on lady.smtp.cz
    <br>
    X-Spam-Level:
    <br>
    X-Spam-Status: No, score=-9.9 required=7.0 tests=BAYES_00,DKIM_SIGNED,
    <br>
     DKIM_VERIFIED,HTML_MESSAGE,RCVD_IN_IADB_LISTED,RCVD_IN_IADB_SPF,
    <br>
     RCVD_IN_IADB_VOUCHED autolearn=disabled version=3.2.5-a24
    <br>
    Delivered-To: pnowak.net-facebook@pnowak.net
    <br>
    Received: from unknown (HELO amy.smtp.cz) (81.95.97.123) by lady.smtp.cz with
    <br>
     SMTP; 14 May 2013 13:12:10 -0000
    <br>
    Received: from in.smtp.cz (leela.smtp.cz [81.95.97.124]) by amy.smtp.cz
    <br>
     (Postfix) with ESMTP id 0E7C474966 for <pnowak.net-facebook>; Tue,
    <br>
     14 May 2013 15:12:10 +0200 (CEST)
    <br>
    X-Greylist: Passed host: 74.63.202.102
    <br>
    X-Virus-Status: Clean
    <br>
    X-Virus-Scanned: clamav-milter 0.97.6 at clam1
    <br>
    Received: from o1.email.getsatisfaction.com (o1.email.getsatisfaction.com
    <br>
     [74.63.202.102]) by in.smtp.cz (Postfix) with SMTP id 873E9120589 for
    <br>
     <facebook>; Tue, 14 May 2013 15:12:09 +0200 (CEST)
    <br>
    DKIM-Signature: v=1; a=rsa-sha1; c=relaxed; d=email.getsatisfaction.com;
    <br>
     h=from:to:subject:mime-version:content-type:list-unsubscribe; s=smtpapi;
    <br>
     bh=9q5KbT+VbJrJ3641Hv+BGoFwf8A=; b=W/GATkB86JEfCKdHh
    <br>
     c4kizUnuOsU8IFAkZGSoD1fWKtf0++VwbUJaJKBYzIsYpLsT3ybeFaN3EQGLQgvA
    <br>
     mSmcm/QXnhkQVjL+TN/bBITgbevM2pB2NhCk47QDe2mr4Ok4RRBr6/qlQcZokEBO
    <br>
     hxz40acfw6eFpo3W1OsNmsehxw=
    <br>
    Received: by 10.16.69.112 with SMTP id mf23.3944.519238274 Tue, 14 May 2013
    <br>
     13:12:07 +0000 (UTC)
    <br>
    Received: from getsatisfaction.com
    <br>
     (ec2-54-245-145-127.us-west-2.compute.amazonaws.com [54.245.145.127]) by mi22
    <br>
     (SG) with ESMTP id 51923827.68e.73592f Tue, 14 May 2013 08:12:07 -0500 (CST)
    <br>
    Date: Tue, 14 May 2013 13:12:06 +0000
    <br>
    From: "eM Client Inc. on Get Satisfaction!"
    <br>
     <noreply.emclient>
    <br>
    To: "eM Client Inc. on Get Satisfaction!"
    <br>
     <noreply.emclient>
    <br>
    Message-Id: &lt;51923826c3c46_a25b641302fa@ip-10-245-14-160.tmail&gt;
    <br>
    Subject: New reply: Automatic set of "From" when reply ?
    <br>
    Mime-Version: 1.0
    <br>
    Content-Type: multipart/alternative;
    <br>
     boundary=mimepart_5192382739570_a25b6413037e
    <br>
    List-Unsubscribe: https://discourse.emclient.com/me/notifications?utm_medium=email&amp;utm_source=reply_notification
    <br>
    X-SG-EID: k0XDUF1nOXsEdcmv7MbDcOl8tbJH6n7WJFnStyC/odjAD1Pev0145cwaRluPAYoIWuLbO46fPgts8DaAqKiGSaoqN+q3AeQNFfTKljEYgMkWQgh50dkBBbeZrGRgxhWq
    <br>
    DKIM-Signature: v=1; a=rsa-sha1; c=relaxed; d=email.getsatisfaction.com;
    <br>
     h=from:to:subject:mime-version:content-type:list-unsubscribe; s=smtpapi;
    <br>
     bh=9q5KbT+VbJrJ3641Hv+BGoFwf8A=; b=W/GATkB86JEfCKdHh
    <br>
     c4kizUnuOsU8IFAkZGSoD1fWKtf0++VwbUJaJKBYzIsYpLsT3ybeFaN3EQGLQgvA
    <br>
     mSmcm/QXnhkQVjL+TN/bBITgbevM2pB2NhCk47QDe2mr4Ok4RRBr6/qlQcZokEBO
    <br>
     hxz40acfw6eFpo3W1OsNmsehxw=
    <br>
    ```
    </noreply.emclient></noreply.emclient></facebook></pnowak.net-facebook></nowak.petr></bounces>

Sorry for the delay - could you please go to the account settings and make sure you have the Alias filled in? Then let me know if it helps. Thank you.

That was the problem. It works now. Thanks George !!!