Automated backup not working

(Version 9.0.1708, Win 11 64bit, Avast One free antivirus)
I cannot get my scheduled backup to run. It always worked without problem on my Win 10 laptop but now it only did for two days on my new Win 11 laptop. I have to manually run it to carry out the action.
Is there some setting I’m missing or is there the tiniest little bug?

Go to Menu > Settings > General > Backup and disable the periodic backup.
Click on Save & Close.

Open Windows Task Scheduler and remove the eM Client task.
Close Task Scheduler.

Restart eM Client and setup the period backup again.

Thank you very much for the reply. I have done as you suggested twice and rebooted the laptop as well in the process. I double checked after the second time/reboot that neither the “Client” program nor the Task Scheduler was showing anything. I then recreated the task in eMClient but I’m afraid to say that it will will not do an automated backup.
All other suggestions welcome.