Auto expand quoted text

It would be useful to include an option in the Read section of Email settings, where quoted text can be expanded by default regardless of conversation settings. Currently quotes are expanded only when conversations are disabled.

This is particularly important when receiving forwarded messages in which there is no sender comment as, in conversation views, the email at first glance appears empty unless the dots are clicked to expand the quoted text.

3 Likes

Agree, when someone forwards me an email, I see an empty email in em client until I click the three dots icon, and must click it every time I get to that email.
Forwarded message hiding could be an option, but never a default feature.
User will decide if he wants to hide the content of received items.
Please, disable this feature and create an option to enable it.

1 Like

I agree this would be great. Most of the daily newsletter emails contain quoted text blocks, which EM client auto-hides.

I see this post is two years old, but still no solution?   I love the way EM Client does conversation mode in the message view only, but the 3 dots are annoying.   I have a client that responds with “Thank you” or “OK”, and I have to click the 3 dots to see what she is approving.  

eM Client Inc. only considers ideas where there is sufficient interest. As I only received two votes on this idea I proposed, it is unlikely that anything will happen. ;-(

Maybe you could also vote, Barbara!

Upvoting this. I don’t want my emails abbreviated and I don’t want to have to click on the three dots to read them. And, this doesn’t only happen with quoted text. This feature should be optional. Thanks!

It is optional. You can disable it in Menu > View > Conversations > Disable Conversations.

Thank you for your reply! But this is not in a conversation. It is in a new email I just got that is not part of a thread. The three dots are hiding part of the email copy and I have to click on them to read the email.

I suppose you can consider that the quoted text in the message does make it a conversation.

This is a feature of conversation mode that hides quoted text behind the three dotes. To disable the dots, disable conversations.

Thanks again! It’s not quoted text, either, but maybe it misreads it since it was sent from a mass email platform. Only one paragraph is hidden and the rest of the text in the same container is not hidden. So it’s bizarre but luckily it doesn’t do it on every email. Thanks again for the insights.

Any thoughts from the eM team about fixing this issue? Worrying that’s it’s been an issue for 5.5 years.

This is not as simple as “disable conversation view”.

Many people respond to parts of e-mails by copying and pasting text from a previous e-mail. This generates a block quote in many e-mail systems, which eM then decides to hide behind three dots when in conversation view.

This clearly should not be hidden when received. Why would anyone want this to be hidden? It causes the receiver to miss key information.

It’s made more confusing when you receive a seemingly empty e-mail (as per the OP).

1 Like

Here’s another example of why this is a problem.

I just received an e-mail reply that had two quotes pulled from my email to the sender.

I had no idea of this, because all it showed in eM client was a white gap - no three dots in the gap, no nothing. Just looked like the sender had pressed enter.

The only way I realised the sender quoted me is because I clicked the three dots under their e-mail because I wanted to see what I said to them. Then it revealed my quotes back in their original e-mail.

This is really not a well-realised part of conversation view.

Other programs that have conversation view don’t remove quotes from inside emails, so why does eM Client?

This can really cause you to miss important parts of e-mails.

2 Likes

Thinking of a way to maybe help with this until a better solution is found - but what about the option to disable the three dots message collapsing when using conversation mode?

That way, we can still have conversation mode on, with all e-mails grouped as a thread, but just accept that if you receive a new email or read an old one, it will show all the previous text underneath it without being collapsed by the 3 dots.

I would much rather this, which is pretty easy to deal with, as you just ignore the text under the current e-mail, than miss important information in an e-mail I receive.

2 Likes

This problem also affects lists that aren’t quotes. So it’s actually collapsing completely valid ways of creating clear lists in e-mails.

BUG: Collapsed/hidden quotes affecting non-quote lists - eM Client

1 Like

what about the option to disable the three dots message collapsing when using conversation mode?

That way, we can still have conversation mode on, with all e-mails grouped as a thread

Plus 1 for this functionality, this would result in a huge improvement to useability IMHO. Is there any hope of this being implemented, @Gary?

Hi,

I just wondered if there was any forward movement with this problem internally?

It’s still very much a problem, and it’s not just about quoted text from previous e-mails.

Sometimes people send e-mails using the “quote” feature of their e-mail client, but are not actually quoting something from the e-mail - they are just using it for formatting purposes.

eMClient hides the text contained in this, which means you don’t see it.

This is obviously quite a problem.

Also, even if they are quoting text that is contained in a previous message, that quote is not redundant at all - they are putting it in to their e-mail in that position for a reason. To remove it causes massive confusion.

There must be a way to fix this problem without disabling Conversation view. I don’t know of any other e-mail client that does this.

Although this is not the topic of my original post, what you ask is changed in version 10 (ETA not yet available).

The full quoted message will still be behind the three dots as that is part of the conversation feature, and it will not change.

But formatted text above that, that is not part of the quoted message but is using the HTML quote tag, will not be hidden.

Ah, that’s sounds great!

So, if I understand correctly, essentially anything that is part of the standard quoted reply (i.e., under the signature area (depending on your settings)) will be behind the 3 dots, but if someone pulls a quote/copies and pastes text and formats it as a quote and puts it anywhere above that, that should display.

That will be a great update! Thanks Gary.

Hi Gary.

Testing out v10 Beta now and glad to see that quoted text shows instead of being hidden. :+1:

Just a bit of feedback in that I am not seeing the second part of what you said, however, that “The full quoted message will still be behind the three dots as that is part of the conversation feature, and it will not change.”

For me, the full quoted message is showing and not hidden behind three dots.

This is preferable to hiding all quotes, but it would be nice if we have the option of hiding full quotes messages behind three dots, whilst still showing quoted formatted text above that.

Appreciate this is obviously still in Beta, but do you think this will become an option?

Thanks!