auto complete is not working

while composing and email, auto suggest/ auto complete is not working

To operate auto suggest you have to right click over words which have been highlighted as incorrect & then select from a drop down box of suggestions

Go to menu/tools/settings/mail/compose and ensure “Automatically complete email addresses when composing” is checked.

How many auto complete addresses can eM support?

As far as I know it is unlimited because the autocomplete function looks for similar addresses in Contacts as well as the previous recipient history.