Attachments divide by zero error

Attachments are downloading with zero size and I get a divide by zero error when trying to open them, as per the image below. I’m on version 6.0.23181.0.

Hi,
please try running this release and see if the issue persists > http://www.emclient.com/dist/v6.0.234…
If it does, please share more information about your account settings so we can analyze the issue (IMAP/POP/Other account? Which mail provider are you using? Is this happening on all your accounts?)

Best regards,
Olivia

Same issue for me; a .pdf file that shows correctly in webmail and on Android shows as zero Bytes (and gives the above divide by zero error if I try to open it) in eM Client.  The provider is Outlook.com and settings are imap-mail.outlook.com port 993,

I am running eM Client v6.0.23421.0

Hello Olivia,
No, that didn’t help. Like Voyager above, I’m running on Outlook.com. It’s an IMAP account and it’s the only one I have.
I’ve just moved to eM Client. I’m seeing on very old messages that I’ve downloaded since installing eM Client and on new ones that have arrived since i installed this upgrade.
I note that for images that show zero bytes, the image still displays in the email but i can’t open or save the file.
Thanks
Charles

Some additional insight I can now share:

  1. All attachments so far have been .pdf files (so I don’t know if other file types are also affected) but sometimes they show as zero bytes and sometimes as the correct file size.  
  2. In one case I was sent the same e-mail twice within 30 seconds; the first one had the .pdf file showing as zero bytes (and giving the divide by zero error on trying to open it) but the second one handled the attachment correctly
  3. If I open an e-mail and then hover the mouse button over the file icon it correctly shows a thumbnail picture of the contents even though the byte size is zero - this implies that the byte size is not actually zero at all

I can add that it applies to all file types. I’ve also observed emails where the jpeg images display inline but have zero size and can’t be downloaded.

It happens also to word and excel attachments. Old attachements (from before 5 october) are OK

Thanks for clarifying all file types, catalpa34.  Your “I’ve also observed emails where the jpeg images display inline but have zero size and can’t be downloaded.” is my item 3 so we are certainly seeing the same problem.  

Interesting date comment, roos; I hadn’t upgraded eM Client for some time until 3 days ago (to see if it solved the problem, which it didn’t) so I wonder if something in the Outlook.com service changed round about that date that is interacting negatively with eM Client - or whether it is coincidental?

@Voyager, I doubt if the problem is a outlook.com service.

I’ve have two different laptops with an eMclient on it, on both is an (different) outlook (=Hotmail) account. One laptop has this divide by zero error, the other laptop has no problem

One difference about this laptop: operating system, Windows 7 (problem) Windows 8.1 (no problem)

Hmm. I’m on Windows 10. I thought that might have been part of the problem, but apparently not.

I think I found the problem, … when you create an account and use the ‘auto setup’

I have no problem, with Attachments divide by zero error. In settings, accounts, server is : m.hotmail.com

When I create, an account using: E-mail, the,manual way with smtp, imap server, ports etc. I suddenly have the Attachments divide by zero error

So, please can someone tell me the difference between the manual and the auto setup of an outlook (= hotmail) account?

To solve this problem, I can throw away the (manual setup) account and create a new (auto setup) account. But I remember I had a couple of months ago, problems with an auto setup account, and switched then to a manaul account.

I dont want every now and then, that I have to change my account!

It there a simple way, to change the account settings, from manual to auto, without loosing any data? Or can you solve the attachment problem on a manual created account?

This is how a jpeg looks. You can see the image but the size is zero.


I then tried to repair the folder, and got this:

I might just have to go back to Thunderbird, though I do prefer eM Client.

I think I’ve worked it out. I’ve gone back and forwards between manual and automatic configuration, and auto works and manual doesn’t. I’ve also tried manually configuring m.hotmail.com, and that doesn’t work either.
I think it might be that eM Client is using the AirSync protocol when auto configured, as do Outlook and Live Mail, rather than IMAP. I know Microsoft was having problems with their IMAP support for several weeks up to about two weeks ago, and I’m not sure whether that/s related or not.
In any case, auto works for me and manual doesn’t.

Interesting to read, thank you catalpa34.

eM Client Support - Before I go to the trouble of rebuilding a huge email account via a slow countryside “broadband” connection, please will you comment on catalpa34’s post and whether it is true.

Thank you,
Voyager

eM Client Support:  Please will you be kind enough to respond per the post above.  Thank you.

Hello,
I’m very sorry for the inconvenience, but we are having trouble pinning down the cause of this issue. It could be connected to the IMAP issue Microsoft was having, as catalpa34 above mentions.
Setting up the account by default to AirSync does seem to get rid of the 0B attachments issue at least.

Best regards,
Olivia

Thank you, Olivia.  I deleted the Outlook account in eM Client and recreated it using auto setup before then leaving it to rebuild all the folders and contents overnight.  All looks well.

Sorry to bring up the issue again but I’m facing exactly the same problem. I’ve just moved from WLM and set up my outlook.com account manually using IMAP. Automatic setup implies syncing of the calendar and contacts over air sync which causes continuos “503 server not available” error notifcations, and therefore not a tempting workaround. Is there a fix available ?

Hi Arild,
Microsoft is currently terminating DeltaSync for their hotmail/outlook/live accounts, which is a crucial part of AirSync, so its interfering with the Contacts and Calendar synchronization. Soon the only way to access mail will be IMAP.
We are working on a way to sync Calendars and Contacts over IMAP and we already have a solution for upcoming version 7, and are finding a fix for version 6 as well. We’ll push it in an update when we make it work.
Thank you for your patience.

Regards,
Olivia