Attachment warning when replying

When replying to an email that has the word “attach”, “attachment” etc in the original or recent body text in the chain, the missing attachment warning pops up, even if I haven’t used it in my reply. This debases the value of the warning as - more often than not - I have to click the “send anyway” option. Could you limit the attachment keyword search to the email text I’ve just written?

Hello Neil, unfortunately this feature allows the dialog to popup if the content of the body contains the word “attachment” in the message body, even in replies, the feature scans the whole body content, unfortunately even previous replies are included in the body so the warning will popup out.

You can however disable the feature completely in your application settings.

Paul thanks for the quick reply. I do understand the current behaviour - I’m suggesting that a beneficial enhancement would be to limit the feature’s search to the new text. Regards…Neil

Thank you for the suggestions Neil, we’ll try to improve this in future releases.

Here’s a perfect example of how the value of the potentially very useful “missing attachment” warning is degraded by the current implementation, which scans all the emails in a chain, rather than just the text written in the current one. This is typical of disclaimers (this one from my financial advisor, but most are very similar) that many businesses and individuals append automatically to all outgoing emails:

"This e-mail, and any attachments, is intended only for the use of the addressee and may contain information that is privileged and confidential. It may not be distributed or disseminated without our permission.  Your attention is drawn to important information on our website xxxxxxx.  If you have received this e-mail in error, please notify us immediately by return e-mail and delete this e-mail and all attachments from your system. xxxxxxxx Limited is authorised and regulated by the Financial Conduct Authority."

So EVERY email from them that I reply to, whether there was previously an attachment or not, results in the warning, meaning that I tend to just click “yes” without thinking about it, and annoying the hell out of me in the process.

Has this been solved? I am having the same issue. Our company signature includes: 

DISCLAIMER:
This e-mail and its attachments contain confidential information…

Outlook is able to ignore the signature and previous replied text when double checking if needing an attachment.  If this has been fixed let me know and I would love to switch that feature.

Thank you!

It wasn’t a problem to be solved but an idea that Neil proposed, and it has since been implemented. When replying to a message where a word like attachment is in the original text, there is no longer a warning that an attachment is missing.

Jeffrey, what you are asking is not currently possible. Unfortunately the signature is still considered part of the new text body in the current versions. But as Paul mentioned, you can disable this warning.

I just looked at the message source, and because of the

tag, it should not be a major undertaking to implement your request Jeffrey.

If you want to propose a new idea to have the signature ignored for attachment-like words, you should do so.

10/4.  I am proposing a new idea to have the signature ignored for attachment-like words.

It’s not something I have had a need for, but I can see the advantage so I will vote for it. :slight_smile:

Gary, good to hear that my idea has been implemented, but how do I get the version that contains it? Help, Check for updates tells me I have the latest version (I’m on 7.1.33101.0), yet the old behaviour (ie show the warning) persists.

Regards…Neil

I am using an internal build, but I loaded 7.1.33101, and I get the same behavior: the attachment-like words in the original text when replying are not flagged.

Can you send me an example message that flags the word when you reply? Right-click on the message and choose Forward > Forward as attachment. Send it to gary@gmx.se

The behavior is different depending on how the original text is quoted. If it is indented, then you are not warned because of attachment-like words in the quoted text.

Ah! Tried that and I no longer get the warning. I haven’t looked at those settings since originally installing and learning emc some 5 years ago. Thanks