Archive folder is not displayed

I have the paid version.

I archived a bunch of emails but there is no Archive folder under Local, and the Local>Inbox is empty. I use Google/Imap and, of course, they’re no longer on the cloud.

Did I just lose hundreds of emails or is Archive hidden somewhere? I don’t see the option to display Archive anywhere.

I don’t normally use “archive” so I ran a test with results below. I am a PRO user but use POP3 not IMAP which may make a difference.
image

Archived IMAP Gmail normally automatically goes in Gmail “All Mail” folder (under your Gmail account) in eM Client, where you can then copy or move it out of there (if you choose) to an alternate folder under Local folder you manually create.

If you cannot see the Gmail IMAP “All Mail” folder, go to your Gmail account online and make it visible via “Labels” heading in Gmail Settings. Then close and open eM Client & it should appear automatically.