Appointments disappear in eM Client, but still shown in the original calendar


if I do set up a new appointment in eM Client it is shown for literal seconds and then disappears. But the appointment is kept in the original calendar. It doesn ́t help using the repair button. I do use version 7.1.33101.0. And there is a error shown in the protocoll as well.
Can you please tell me how to solve this issue?

Thanks a lot in advance!


What is the error you are getting?

Are you maybe saving the appointment to a read-only calendar?

Try saving to a different calendar by clicking the link at the bottom of the new event window.

I tried it on another calender (gmail), there it is working. The other one (based on Horde) isn ́t working. It says something about that an identified element has an invalid format.

But I checked and it isn ́t a read only calendar. I don ́t know, what to do…

How did you add the Horde one to eM Client?

By entering the CalDAV URL - Accounts -> calendar -> CalDAV

OK, so if there is some error with that calendar, then maybe it is not correctly setup. Are you otherwise able to see events in that calendar?

Yes, if I do add them in Horde, I am able to see them. That ́s why I ́m a little curious. Is there a different way to set it up?

CalDAV can be a pain if it is not setup correctly, and in your case it appears that the calendar is read-only in eM Client.

If you have a Pro License, you could open a support ticket with eM Client. Using your CalDAV logs they should be able to find where the problem is.

Thanks a lot for your answers! But I don ́t have a pro licencse, due to the fact that I ́d liked to try it before. But if it isn ́t working this program isn ́t applicabale for me.

Do you know how I ́m able to see if it is read-only?

Generally, if you save an event to a calendar then it disappears after a few seconds, the calendar is read-only.

Sometimes you get a pop-up, but not always.

Hmmm, ok. Than this might the case. I hope I can figure out how to set it up properly :smiley:

I am not able to find a solution - means I have to look for another program :frowning: or does somebody have an idea???

The solution is still to find the correct CalDAV URI. Maybe your server admin can help you?

I tried every f***ing possible URL. Our admin says, that due to the fact it is an old CalDAV version it might cause problems. It is a pain in the arse…

Seems they were right. ;-(

Unfortunately… it would be better if they weren ́t this time :smiley:
But thanks a lot for your help!