Always send later-option

I’m mostly using the “Send later” option, to always send mails later.

I would love to see a feature, where I could enable and select a time for the default “Send” too.

  • new option to set a period in minutes for “Send” (default == 0 == immediately)

That option is available in the upcoming version 8.

Great. Thanks for the info.
Is there already a date for the release of version 8 for mac?

That’s great. Consider it solved for now :wink:

Still hope there are longer times like 15, 30 and 60 minutes available…  (never get, why something like this is not just an input field for numbers instead a select box with predefined values.)

Initially the release date (for Windows) was late Spring. If you want to test it now, you can get the beta for Mac in the Release History.

For longer periods you can disable the setting to send immediately (in the same screenshot above) and then go to Menu > Tools > Settings > General and change the Synchronize interval to whatever you want. That will also affect Calendars and Contacts sync intervals, but it will also only send your messages on that interval.

That does not mean that when you hit Send, the message will wait for 30 minutes, but it does mean that only once every 30 minutes your messages will be sent. 

Thanks, Gary. I wait and look forward to the appointment ;>)

Ah thanks, that can I apply already now, as I’m already syncing   only once an hour to avoid distraction.

That sync interval does not affect incoming IMAP messages, which will continue to arrive in real-time, but does apply to POP3 (and IMAP sub-folder) incoming messages.

If I have a message that is in a “send later” queue, how to do interrupt that process? For example, I have all messages set to send in 1 minute. But 10 seconds after I hit the send button, I realize that I want to make an edit to the email. How to go back into that message (and prevent it from sending in 1 minute) ?


Go to the Local Folder Outbox and open the message. You can then edit it, or change the Send Later option.

If Local Folders are not visible, you can enable them in Menu > Settings > General > General > Show Local Folders.

Local folders! Thank you.

If I set emails to ‘send later’ and my computer goes to sleep they are not being sent.
Instead, the minute I logged in, they are being sent all together with the login time stamp.
Is there a way to change that?

Yes, eM Client needs to be running to send the messages, so if the computer is shut down, nothing will happen until it is running again.

oh ok, thanks a lot!
I wish there will be a possibility to host the emails at your end somehow (even as a paid service) in the future.
Most of times I’m working super late and I don’t want to send my clients an email in the middle of the night but also not in the afternoon when I’m actually getting up :sweat_smile:
keeping the computer running non stop takes a lot of energy :frowning: but I guess that will do for now.