All inboxes shows unread email twice

I am running the latest version on 6.0.2.  Just switched from windows live and imported all data.  I have 4 email accounts.  Two gmail, one, and one  When I use the all inboxes view the email from my primary gmail account shows twice.  If I delete one of them, they both disappear.  I want to use eM as my new mail client, but I need a fix for this issue.

I think the duplicates are becuase my gmail account is reflected in my live account, so when I slect all inboxes it shows twice.  is it possible to control what accounts are shown in the all inboxes view?  If yes, I could remove the live account from the list.  However, I MUST continue to show the live account calendar entries.  These I can not turn off since for a while that is my main calendar.

Hello Gary, unfortunately it is not possible to change which accounts will be displayed or collected by the All Inboxes folder, this folder simply collects mail from all your accounts, if your account is mirroring one of your gmail accounts I can only recommend to disable the forwarding or copying of items to this account in order to see each item once in this folder.