A Rule we created has stopped filtering incoming emails... VERY Annoying!! :-(

For 15 years we have had a domain name to which all our emails come to @XXXXXXX.co.uk

When registering our email address with a particular company we always use that companies name before the @ sign hence, registering on www.whatevercompany.com we would give our email address as whatevercompany@XXXXXXX.co.uk

The reason for this is because if we start getting spam from that particular company or another company ‘they’ have shared that email address with ie: whatevercompany@XXXXXXX.co.uk we can simply add that name ‘whatevercompany’ to our ‘BlackList’ within a ‘Rule’ we have created which permanently deletes the email!

No Spam ever need fill our Inbox! YEAH!!! Not So! :frowning:

This Rule has worked perrrrrrrrrfectly for all these years with other email clients annnnd it has too with eM Client for the last 6 month but Sadly this Rule has stopped working within eM Client which is VERY Disappointing not to mention the Annoyance of having dozens of unwanted emails fill our Inbox!

If anyone can explain why this rule might have stopped working and how to fix it we would be Thrilled to hear from you!

Thanks in anticipation!

Hi, what version of eM Client are you currently using on your computer, can you please check for the exact version number in Help > About? What mail service are you using with eM Client?
To blacklist an email domain you should use the “Move to Junk” button, which automatically adds the address/domain to the blacklist in eM Client under Tools > Rules > Blacklist.

Or are you having issues with a server side rule, setup in your webmail?

Thank you,
Paul

Thanks for your prompt reply Paul!

The version of eM Client we are using is 6.0.21040.0. Our Mail Service provider is Utility Warehouse but the issue we have is not ‘Server’ Side’! It is a rule set up within the above mentioned version of eM Client

I understand that the ‘Move to Junk’ button is one way to blacklist domains but we would prefer to have the ‘Rule’ doing its job properly!

The reason for this is that domains that we initially register with ie: Company 1 whatevercompany@XXXXXXX.co.uk may share that email address with a dozen other companies say… companies 2 - 12 who then do exactly the same and share it with further companies. The number of companies who then have and share this email address obviously just keeps multiplying with a never ending number of companies domains having to be blacklisted!

Having a ‘Rule’ working properly is by far the better option as we have just 30 (approx) whateverthecompany@XXXXXXX.co.uk email addresses in the Rules’ Sent to list!

Hence our one and only ‘Rule’ is simply… After message has been RECEIVED sent to WHATEVERTHECOMPANY@XXXXXXX.CO.UK permenantly delete! Hey Presto!

This rule has worked fine with other email software since day one (14 years ago) so we hope you can come up with a solution to this problem with eM Client!

Finger Crossed!
Thanks in anticipation!

Hi again Marrach, I can’t seem to replicate this issue and all my Rules seem to be working as expected. Please try to update your eM Client to this release and check if the issue persists, http://www.emclient.com/dist/v6.0.21289/setup.msi .

If it does, please navigate to Tools > Settings > Advanced and turn on Rules logging.

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    If the issue reoccurs, please go back to the advanced settings window and click on “Send logs” to submit the logs to my email, mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul

Thanks for that! Will give it ago! Would you suggest doing a complete uninstall before reinstalling the updated version? Obviously we don’t want to loose our contacts or current emails!

Hi again, updating the application using the installer should do the trick, no need to uninstall, neither of the options however won’t cause data loss, as the user folder containing your user information is kept in your roaming folder even after uninstalling the application.

Hope this helps,
Paul

G’day again Paul,
I updated the application using the installer as suggested but Saaaadly the issue is unresolved!!

Our one and only rule is ‘Not’ working and our inbox is being flooded with unwanted spam!
Would appreciate further instruction to overcome our problem please!?!? We really don’t want to have to go and find another App to do email! Fingers crossed a solution will be found! :wink:

Will send log once you confirm where to send it!
Thanks in anticipation!
Marshal

Hi again Marshal, in case the issue persists, please navigate to Tools > Settings > Advanced and enable “Rules” logging.

  1. Savet the settings
  2. Restart the application
  3. Replicate the issue
    When the issue reoccurs, please go back to the advanced settings window and submit the logs to us using the “Send logs” button and send me the logs to mcgregor@emclient.com with a reference link to this forum topic.

Also please include a screenshot of your rule setup (the faulty one), and attach an exported email message that wasn’t processed by the client.
To export the message into .eml drag and drop it onto the email or your desktop.

Thank you,
Paul

Sent Paul! Look forward to your response! Cheers!

Hi again, thank you for the received data, based on the look at the Rule setup and the received message I believe you don’t have the sender’s email added as to be processed by the rule.

The message has been sent by ‘@oldstuff.org’ domain which is not included on the list. Please make sure to add the address to the list or use the blacklist to add it on the eM Client’s blacklist of domains/emails. Next time email would be received from this address it should be processed.

However note that application rules are only processed when new unread message is received, for messages marked as read by another device, the rule can’t be processed.

Thank you,
Paul

Sorry Paul, think there’s a misunderstanding here…! Yes the message has been sent by ‘@oldstuff.org’ domain which is not included on the list… Yes you have that correct BUT the ‘Rule’ isn’t sent by! It is ‘Sent to People’ (as in the screens shots) for which we have our list of unwanted email addresses to which the unwanted emails are sent to!

The other thing is Paul this rule has worked fine for many years with other MUA’s and also with emclient for the last 6 months! It just stopped suddenly with emClient!

Fingers crossed again we can find a solution!!

Hi again Marshal, thank you for the clarification and sorry for my mistake.
We’ve checked the logs you’ve sent us and when the message you’ve attached to your email is being processed, the rule seems to contain another condition and that the message has to contain a certain subject to be processed.

Can you please make absolutely sure, non of these options are set for neither of your rules to make sure the rule is processed?

Thank you,
Paul