24 hour time does not work in Calendar

Previous topic says that eM Client uses the system time and date settings. I have system time setting as 24 hour, but Calendar shows time as AM or PM. Is this a program bug?

Hi, I took a look to our code and we detect 12 vs 24 by “tt” expression in Time Regional Options string. So fe. for “H:mm:ss” we set it to 24 hours and for “h:mm:ss tt” we set it to 12 hours.
Probably it would be better to detect, if it contains “h” or “H”, Now I’ve changed that behaviour and it will be available in v2.6.

Thanks Michal. I have the time set to HH because I want the leading 0. Your proposed code change should detect this properly.