Search function not working suddenly

  • 2
  • Question
  • Updated 2 years ago
It used to be that I could type a word, phrase, number, etc. (maybe in quotes,. maybe not) into the search field and search my inbox, and the search would work perfectly.  Now, more often than not, the search comes up as "There are no messages to show in this view".  I can even copy something directly out of a message, then search for it as a test, and it's not found.  Has something changed?  Thanks - I love eM Client, so hoping this is an easy fix :)
Photo of Kyra Marino

Kyra Marino

  • 11 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Paul - Technical Support

Paul - Technical Support, Employee

  • 11315 Posts
  • 529 Reply Likes
Hello Kyra, what version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About?

Can you please check your search preferences by clicking on the little magnifying glass in the search bar and make sure you have the search setup to go through all folder (and not for example only selected ones) and that the search is searching for subject, sender, recipients and body and not one of the headers for example maybe.

Thank you.
Photo of John Hood

John Hood

  • 2 Posts
  • 0 Reply Likes
Paul. This did it for me. Thanks. I couldn't figure out why Google web mail would show an email and Em Client wouldn't.  Turned out as you said.  I set to "Subject, Sender recipients and body." with IMAP account "Download Messages for Offline Use."    Now I can see 1 to 1 search results.  Thanks again. - John  
Photo of Kyra Marino

Kyra Marino

  • 11 Posts
  • 0 Reply Likes
I think that worked, although I'm not sure how my settings got changed on me :)  Thank you very much!
Photo of Paul - Technical Support

Paul - Technical Support, Employee

  • 11315 Posts
  • 529 Reply Likes
Glad it works, please make sure to let us know if you come across any other issues or questions about the application, we'll be happy to help.

Thank you,
Photo of Barbara Collins

Barbara Collins

  • 18 Posts
  • 1 Reply Like
Hey Paul,

I find that if I search All Folders, and Subject, Sender, Recipients & Body the search wheel spins, and spins until I escape out of it.

If it only search in one field the results pop up immediately.

Any suggestions?
Photo of Paul - Technical Support

Paul - Technical Support, Employee

  • 11315 Posts
  • 529 Reply Likes
Hello Barbara, this may be due to having the "Body" included in the search, note that by default eM Client only synchronises the message headers and doesn't automatically download the message's body when new email is available on the server, unless you have the "Download messages for offline use" enabled in the application/account settings.

Otherwise the body content can only be downloaded when you click on the message, and if your body content is not complete and only some of the messages can be searched, eM Client search feature may be taking some more time. Also note that searching through the body of the message is the most complicated/or time consuming process while performing search (there's a highest possible number of matching options).

Regards,
Photo of Barbara Collins

Barbara Collins

  • 113 Posts
  • 10 Reply Likes
Yes, I have "Download messages for offline use".

How can I abort a search.  That has been my biggest problem.  When I see a search is taking a long time, I can't get out of it.
Photo of Paul - Technical Support

Paul - Technical Support, Employee

  • 11315 Posts
  • 529 Reply Likes
All you should need to do is to click on the red cross in the search field.

Regards,