em Client crashed, then all settings (including accounts) was lost

  • 1
  • Problem
  • Updated 4 weeks ago
My EMC "was not closed properly" - although I don't know, what are the parameters for closing EMC properly, because I always wait to ensure, that there is no sync at the moment, I close EMC first and after that I shutdown my computer. And despite this, I often get an error "program was not closed properly" during next launch...

Anyway, after opening EMC yesterday, I accidentally pressed "cancel" when EMC was checking database etc. (this small windows after not closing properly).

And when I tried to re-launch EMC again, I had only local folders, without any other account - I've got 1 IMAP mail, 1 GMail and 1 CalDAV account. It was all gone - there was 0 accounts in settings, I've got no tree of folders in the left pane, no mails, no calendars, no tasks, NOTHING.

Every file was still on the disk in EMC storage folder, but despite I was trying to launch EMC several times, even after Windows restart, I've got no account.

Good thing, that I'm paranoid and I've always got 5 copies made every day, so I was able to restore my "yesterday" backup (and do some sync afterwards), but still this is very bad behaviour.
Photo of raven66

raven66

  • 39 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Gary Curtin

Gary Curtin

  • 6197 Posts
  • 713 Reply Likes
Not closing properly is a know issue. All I can say is don't cancel the database check.
Photo of JMac

JMac

  • 4 Posts
  • 0 Reply Likes
The same thing happened to me today. I hit cancel and lost everything. Isn't there a way to get EMC to connect to its database again?? This is really bad behavior for any software.